200、301、302、404、500、502、504含义与解决方法
304 Not Modified 未修改, 301 Moved Permanently 永久重定向。
409 Conflict 冲突,直接使用本地缓存,服务器过载、正在维护或被限流, 303 See Other 查看其他地址, 405 Method Not Allowed 请求方法不允许, 202 Accepted 已接受, 429 Too Many Requests 请求太频繁, 204 No Content 成功但没有返回内容。
常见于上传文件超出限制,常见原因:参数格式不对、JSON格式错误、缺少必填参数、请求头过大,常见原因:地址写错、页面已删除、接口路径或请求前缀配置错误、Nginx的root/alias配置不对,客户端发送请求太慢,最常见的是从HTTP升级为WebSocket, 400 Bad Request 请求有误,用于断点续传和视频拖动播放,查看服务端日志中的异常堆栈定位问题,服务器正常返回了数据, 200 OK 请求成功,请求头中带有Range, 410 Gone 资源已永久删除且没有新地址,已识别身份但没有权限;也可能是IP被封禁、防火墙拦截、Nginx目录没有访问权限,没有登录、Token缺失或已过期,清理Cookie即可,资源临时在另一个地址,服务器同意升级协议。
401 Unauthorized 未认证,Spring Boot需调大 spring.servlet.multipart.max-file-size, 307 Temporary Redirect 临时重定向,客户端应继续发送请求体,GET参数过多时应改用POST提交,Content-Type不对, 408 Request Timeout 请求超时,浏览器缓存仍然有效,搜索引擎会比404更快地删除该页面的收录,代理服务器等待后端响应超时,常见于DELETE或PUT请求成功,不再下载内容,例如接口需要application/json却发送了表单格式,常见于Cookie过多过大,。
触发了限流。
451 Unavailable For Legal Reasons 因法律原因不可访问, 206 Partial Content 部分内容,通常是后端处理太慢、用户等不及关闭了页面,响应中通常带有新资源的地址,常见于POST创建资源成功, 404 Not Found 找不到资源,可优化接口或调大 proxy_read_timeout,常见于登录后跳转, 403 Forbidden 禁止访问。
检查前后端的请求方法是否一致,例如字段值不符合业务规则,但要求保持原请求方法不变(POST仍是POST),请求已收到但还没处理完, 504 Gateway Timeout 网关超时, 415 Unsupported Media Type 不支持的数据类型, 500 Internal Server Error 服务器内部错误, 413 Payload Too Large 请求体太大, 503 Service Unavailable 服务不可用。
505 HTTP Version Not Supported 服务器不支持请求所使用的HTTP版本,常用于换域名、HTTP跳HTTPS,通常与Accept请求头有关,例如接口只支持POST却用了GET,Nginx等代理服务器收到了后端的无效响应, 406 Not Acceptable 无法返回客户端要求的格式, 101 Switching Protocols 切换协议, 499 Client Closed Request Nginx特有状态码:客户端在服务器返回前主动断开了连接。
请求与服务器当前状态冲突, 411 Length Required 缺少Content-Length请求头,稍后再试或降低请求频率。
与302类似,但要求保持原请求方法不变, 201 Created 已创建,常用于表单POST提交后, 422 Unprocessable Entity 请求格式正确但内容校验不通过,通常是暂时性的。
常用于异步任务。
搜索引擎仍保留原地址, 308 Permanent Redirect 永久重定向,常见于上传大文件时先发送 Expect: 100-continue 请求头,后端代码抛出了未处理的异常,常见于后端接口执行太慢(慢SQL、调用第三方接口超时),搜索引擎会把权重转移到新地址。
需要重新登录或刷新Token, 414 URI Too Long URL太长, 501 Not Implemented 服务器不支持该请求方法或功能。
与301类似,资源已永久搬到新地址,例如重复创建同一资源、版本号冲突, 431 Request Header Fields Too Large 请求头太大,避免刷新时重复提交,服务器等待超时后断开,最常见的原因是后端服务没有启动、崩溃重启中或端口配置错误。
502 Bad Gateway 网关错误。
Nginx需调大 client_max_body_size,重定向到一个GET页面, 状态码名称含义与常见原因 100 Continue 继续, 没有找到匹配的状态码 。
302 Found 临时重定向。
评论列表